[ET Trac] [Einstein Toolkit] #670: commit 166d77a440a5 and b5f8b4ff16fb does not compile with gfortran

Einstein Toolkit trac-noreply at einsteintoolkit.org
Wed Nov 16 12:30:04 CST 2011

#670: commit 166d77a440a5 and b5f8b4ff16fb does not compile with gfortran
  Reporter:  rhaas   |       Owner:  diener  
      Type:  defect  |      Status:  assigned
  Priority:  major   |   Milestone:          
 Component:  Carpet  |     Version:          
Resolution:          |    Keywords:          

Comment (by rhaas):

 I tried that (actually before I send the original ticket) and tried again
 right now. I get
  In file

       type(ptr), dimension(:), allocatable, intent(in) :: sregions
 Error: ALLOCATABLE attribute conflicts with DUMMY attribute at (1)
 I removed those as well next and actually had to remove the -std=f2003
 (otherwise it complains about Cactus' CCTK_POINTER being a non-standard
 integer*8 type). It then compiles but I have no idea if it is still doing
 the right thing in this case (since I had to remove the allocatable not
 just the intent). I am not very familiar with Fortan at all :-(

 gcc 4.1 is certainly very very old by now, it does not even support
 OpenMP. The only reason why I think we mights still care about it is that
 it still is the compiler used in RedHat 5 systems. Since I expect that
 some groups still use this version on their workstations (Caltech, GT that
 I know of) at least for a while (RedHat 6 is out and uses a newer
 version). I don't know if it is a good idea to have a base component
 (Carpet) that does not compile out of the box with the OS supplied
 compiler. If there was a simple way to work around the issue (eg. if
 removing just the intent from the pointers would have been enough) I would
 have preferred that.

Ticket URL: <https://trac.einsteintoolkit.org/ticket/670#comment:3>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit

More information about the Trac mailing list