#2602: include Regge-Wheeler-Zerilli gauge self-force code in ET
| Reporter: | Samuel Cupp |
| Status: | new |
| Milestone: | ET_2022_05 |
| Version: | development version |
| Type: | enhancement |
| Priority: | major |
| Component: | Other |
Comment (by Peter Diener):
I have carefully checked the source code and have the following comments and requests for changes at this time:
module_scalar_rwz.f90 should be renamed to module_rwz_schw.f90
submodule_scalar_rwz_implementation.f90 should be renamed to
submodule_rwz_schw_implementation.f90
In module_scalar_rwz.f90:
Line 16: The ford link [[submodule_scalar_schw_implementation.f90]] should be
changed tp [[submodule_rwz_schw_implementation.f90]]
Line 29: Ford comment should not say scalar field and point charge but rather
RWZ metric perturbations and point mass.
Line 76: [[scal_schw_save_globals_1]] should be [[rwz_schw_save_globals_1]]
Line 79: [[scal_schw_save_globals_2]] should be [[rwz_schw_save_globals_2]]
Line 82: [[scal_schw_load_globals]] should be [[rwz_schw_load_globals]]
Line 85: [[scal_schw_apply_filter]] should be [[rwz_schw_apply_filter]]
Line 87: [[scal_schw_flux]] should be [[rwz_schw_flux]]
Line 88: [[scal_schw:flux]] should be [[rwz_schw:flux]]
Lines 93-98: Why 2 functions for outputting coordinates for initial data codes?
Line 133: [[scal_schw]] should be [[rwz_schw]]
Line 141: [[scal_schw]] should be [[rwz_schw]]
Line 149: [[scal_schw]] should be [[rwz_schw]]
Line 157: [[scal_schw]] should be [[rwz_schw]]
Line 164: [[scal_schw_flux]] should be [[rwz_schw_flux]]
Line 165: [[scal_schw:flux]] should be [[rwz_schw:flux]]
Line 177-192: Again, as above, we two versions of the routine to write out
coordinates for the initial data code.
In submodule_scalar_rwz_implementation.f90:
Line 52: The allocation of the equation name character variable should be
of length 8 rather than 18.
Line 325: Why is the code for settinp up an initial Gaussian profile commented
out when use_particle is .false.?
Line 352-360: As we currently only have an effective source for circular
orbits, the code should abort with an error message if use_generic_orb
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2602/include-regge-wheeler-zerilli-gauge-self