#2248: incorrect use of "opcodes" for "operation_codes" param table entry in AEILocalInterp users
Reporter:Roland Haas
Status:new
Milestone:
Version:
Type:bug
Priority:minor
Component:

Some thorns using AEILocalInterp incorrectly name the table of operation codes (plain interpolation, derivative, etc.) "opcodes" instead of the correct "operation_codes". Apparently an old api proposals (2.2) did indeed use "opcodes" and the affected thorns are probably descendants of a code using this early API.

The affected thorns are:

None of the thorns actually produces incorrect results since they all set the operation to be 0 (plain interpolation) which is the default.

In all cases the fix is to change "opcodes" to "operation_codes" in the name of the table entry. Changing the name of the variables used to hold the operation codes is optional.

Kindly pointed out by @Shawn Rosofsky who ran into this when actually having to compute derivatives.

--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2248/incorrect-use-of-opcodes-for