Hi Ian,Thanks for noticing that I don't have the naming correct. I believe I fixed it. I am attaching the revised script. However, I still get a crash. Here is the last part of the make with a complaint about sqrtdetg which I don't understand, as it seems that sqrtdetg is properly mentioned and computed in the script. Can you or someone in the list please let me know what's the matter now?
Checking status of thorn CT_BrillAnalyticCOMPILING arrangements/Cosmology/CT_Analytic/src/Boundaries.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_BY_Calc.ccCOMPILING arrangements/Cosmology/CT_BrillAnalytic/src/Boundaries.ccCOMPILING arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalyticCoefficients.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_ExactBoundary.ccIn file included from /Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalyticCoefficients.cc:14:0:/Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalyticCoefficients.cc: In function 'void CT_BrillAnalytic::CT_BrillAnalyticCoefficients_Body(const cGH*, int, int, const CCTK_REAL8*, const CCTK_REAL8*, const CCTK_REAL8*, const int*, const int*, int, CCTK_REAL8* const __restrict__*)':/Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalyticCoefficients.cc:220:84: error: 'sqrtdetg' was not declared in this scopeconst CCTK_REAL PDstandardNth1sqrtdetg CCTK_ATTRIBUTE_UNUSED = PDstandardNth1(&sqrtdetg[index]);^/Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/Kranc.hh:120:39: note: in definition of macro 'KRANC_GFOFFSET3D'(*(CCTK_REAL const*)&((char const*)(var))[cdi*(i)+cdj*(j)+cdk*(k)])^/Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalyticCoefficients.cc:220:68: note: in expansion of macro 'PDstandardNth1'const CCTK_REAL PDstandardNth1sqrtdetg CCTK_ATTRIBUTE_UNUSED = PDstandardNth1(&sqrtdetg[index]);^make[3]: *** [CT_BrillAnalyticCoefficients.cc.o] Error 1make[2]: *** [make.checked] Error 2make[1]: *** [/Users/comerduncan/Cactus/configs/sim/lib/libthorn_CT_BrillAnalytic.a] Error 2make[1]: *** Waiting for unfinished jobs....COMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_Exact_Calc.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_ExpandingLattice_Calc.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_LumpBoundary.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_Lump_Calc.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/CT_Analytic_Poisson_Calc.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/Kranc.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/RegisterMoL.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/RegisterSymmetries.ccCOMPILING arrangements/Cosmology/CT_Analytic/src/Startup.ccCreating /Users/comerduncan/Cactus/configs/sim/lib/libthorn_CT_Analytic.amake: *** [sim] Error 2Here is the last
Thanks for your help.Comer<CT_BrillAnalytic.m>On Mon, Sep 7, 2015 at 6:21 AM, Ian Hinder <ian.hinder@aei.mpg.de> wrote:On 4 Sep 2015, at 16:11, Comer Duncan <comer.duncan@gmail.com> wrote:I have pasted the attempted build to pastebin: http://pastebin.com/YNDgRKNVThere are several complaints there which may be either due to unseen errors in my Kranc script or other unrelated things. Please let me know if you see something. Thanks very much.Aha! You have a calculation with a name which is the same as the thorn name. Kranc uses the thorn name as a C++ namespace, and calculation names as C++ function names, and these are not allowed to conflict. This is the error you are seeing:• In file included from /Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalytic.cc:14:0:• /Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/Kranc.hh:10:28: error: 'namespace CT_BrillAnalytic { }' redeclared as different kind of symbol• namespace CT_BrillAnalytic {• ^• In file included from /Users/comerduncan/Cactus/configs/sim/bindings/include/CT_BrillAnalytic/cctk.h:6:0,• from /Users/comerduncan/Cactus/arrangements/Cosmology/CT_BrillAnalytic/src/CT_BrillAnalytic.cc:11:• /Users/comerduncan/Cactus/configs/sim/bindings/include/CT_BrillAnalytic/cctk_ScheduleFunctions.h:35:6: note: previous declaration 'void CT_BrillAnalytic(cGH*)'• void CT_BrillAnalytic (CCTK_ARGUMENTS) CCTK_ATTRIBUTE_NONNULL(1);• ^I had never thought of this issue before; Kranc should prevent you from doing this and give an error at Kranc time. I just created in issue for this: https://github.com/ianhinder/Kranc/issues/132. You should just be able to change the name of the calculation from thornName to thornName <> "_<something>".In general, I would recommend prefixing all calculation names with the thorn name, to avoid possible conflicts with other thorns. Cactus doesn't have any thorn-based scoping mechanism, so all scheduled functions are in the same namespace. You have some calculations called "formgk" and "gupper". Probably they are fine, but in principle they could conflict with other thorns, so prefixing the names with the thorn name is much safer.Ideally, I think I would like Kranc to automatically add such a prefix, but this would break backward compatibility. Maybe Kranc should print a warning if the calculation name does not start with the thorn name (https://github.com/ianhinder/Kranc/issues/133).
_______________________________________________
Users mailing list
Users@einsteintoolkit.org
http://lists.einsteintoolkit.org/mailman/listinfo/users