I want to add that this change would be implemented in the same way as previous changes: There would be a parameter that chooses which file name format to use, and the default setting for this parameter would (at least initially) be backward compatible, i.e. one would explicitly need to set this parameter to see this change.
Regarding the new file name, I prefer a single dot "." instead of the double colon "::". A single dot is commonly used to access fields in a structure or member in a class, so that thorn.variable or thorn.group make sense. I don't see a reason to use two separating characters. Cactus chose :: because this is what C++ uses for namespaces; if we want to follow Java or Python instead, we would use a single dot instead.
-erik