This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "Carpet — Adaptive Mesh Refinement for the Cactus Framework http://carpetcode.org/".
The annotated tag, ET_2013_05_v0 has been created at 8c22b87ed5d379b0d167edfb6600f22a7e3ad810 (tag) tagging c8bbd52a3ddfe031ba4789bee3a8ab72ecab4e9f (commit) replaces carpet-6-init tagged by Frank Löffler on Mon May 27 17:20:47 2013 -0500
- Log ----------------------------------------------------------------- ET_2013_05_v0 tag
Christian Reisswig (3): Introduce parameter "additional_overlap_zones" to control the amount of additional (user-requested) overlap zones. CarpetInterp: New ENO2 interpolator. Merge branch 'master' of carpetcode.org:carpet
David Radice (1): CarpetIOHDF5: Sliced HDF5 output index file not stored correctly
Erik Schnetter (183): CarpetLib: Allow assigning a region to itself CarpetLib: Allow (again) merging regions that contain process trees Carpet: Disable storage for point_classification CarpetLib: Implement bboxset::contains(vect) CarpetLib: Store level_boxes in dh structure CarpetLib: Do not interpolate from buffer zones, if requested CarpetIOASCII: Pass vectors by reference CarpetIOASCII: White space change CarpetIOASCII: Implement using grid::coordinates to output coordinates Carpet: Remove outdated backtrace function declarations CarpetLib: Clean up backtrace generation Carpet: Correct errors with adaptive time stepping LoopControl: Change printstats default to "no" Remove Carpet's mechanisms to deal with how to call isnan CarpetIOF5: Correct calls to Carpet::Timer Carpet: Correct #ifdefs in CarpetSimpleMPIDatatypeLength Carpet: Requirements: Add aliased function to invalidate variables Carpet: Re-indent timer macros CarpetLib: Remove restrict qualifier from pointer cast Carpet: Correct errors in adaptive step size handling Carpet: Requirements: Warn about unnecessary syncs Carpet: Requirements: Add precondition to clause_t::active_on_timelevel CarpetRegrid2: Perform domain decomposition only when a refinement level changes CarpetRegrid2: Correct snapping to coarse grid for cell centering Carpet, CarpetRegrid2: When comparing refined regions treat non-existing levels as empty Carpet: Execute CPINITIAL only after initial data setup, not after recovering Carpet, CarpetLib: Move #define _GNU_SOURCE to correct file CarpetLib: Update cycle.h from upstream CarpetIOF5: Free HDF5 data when closing files Carpet: Add test cases checking cctk_time during initial data setup Carpet: Set NPROCS for kasner test cases Carpet: Correct comment CarpetRegrid2: Use "isfinite" instead of "not isnan" Carpet: Correct switch statement in CarpetMPIDatatype CarpetLib: Use correct MPI reduction operator for product reductions CarpetLib: Add self-checks to MPI reduction operators CarpetReduce: Avoid duplicate local variables CarpetReduce: Use self-defined MPI operators for complex numbers CarpetReduce: Do not access NULL pointer CarpetMask: Add missing OpenMP reduction clause CarpetLib: Define dh members tallying the size of refinement boundaries LoopControl: Add missing copyprivate CarpetIONirvana: Require MPI Allow padding in transport operators CarpetLib: Re-enable OpenMP collapse clauses CarpetLib: Set up all timers on all processes all the time CarpetLib: Make th::time_interpolation_during_regridding public CarpetIOF5: Various improvements Carpet: Simplify code Carpet: Turn time level / prolongation operator warning into an info message CarpetLib: Support padding in enovol prolongation operator Carpet: Re-apply init_fill_timelevels after postregridinitial CarpetLib: Use "process" instead of "processor" in comments and output CarpetLib: Add default case to switch statement CarpetLib: Correct process number in bbox output Carpet: Initialise TimerNode fields in correct order Carpet: Avoid unused and uninitialised variables Carpet: Check return value of dup() CarpetRegrid2: Correct output of refinement level during AMR CarpetRegrid2: More verbose info output during regridding CarpetLib: Check HRSCC_GLL_ELEMENT_HH instead of HRSCC_HH CarpetLib, CycleClock: Move cycle counting clock into its own thorn Carpet: Use dup2 instead of dup do control destination file descriptor CarpetLib: Ensure allocated memory is aligned for vectorisation CycleClock: Reduce wait time for determining cycle tick CycleClock: Determine elapsed time via integer arithmetic CycleClock: Optimise x86-64 PGI implementation CycleClock: Support Blue Gene/Q CycleClock: Abort compile if architecture is not supported CycleClock: Undo debugging change Carpet: Remove backup files CarpetReduce: Remove empty file Carpet: Initialise all timing variables CarpetReduce: Support array padding (cctk_ash) CarpetReduce: Clean up code defining reduction weight masks CycleClock: Handle Cray compiler CarpetLib: Rewrite array padding LoopControl: Rewrite LoopControl: Circumvent Cray compiler bug LoopControl: Run tests only with 2 processes CarpetLib: Remove unused variables CarpetIOBasic: Simplify code and avoid compiler warnings CarpetIOHDF5: Remove unused variables, initialise other variable to avoid compiler warnings CarpetIOHDF5: Make variable unsigned to avoid compiler warning CarpetLib: Explicitly convert values to signed CarpetLib: Use C++ wrapper madd instead of mul and add CarpetLib: Disable DGFE operators if building without DGFE to avoid compiler warnings CarpetIOBasic: Simplify code and avoid compiler warnings (again) Carpet: Correct load-balancing algorithm to really prefer splitting in the z direction LoopControl: Store loop bounds in the provided variables LoopControl: Correct indexing error with vectorisation CarpetIOASCII: Update test results after domain decomposition change Carpet: Return cctk_ash instead of cctk_lsh in CCTK_ArrayGroupSizeB Carpet: Use cctk_ash where necessary in poisoning and checksumming CarpetLib: Rename argument to vect::index from lsh to ash LoopControl: Add assert statements to loop macros to catch indexing errors LoopControl: Update Fortran macros to follow cctk_Loop API TestLoopControl: New thorn TestLoopControl: Use module loopcontrol LoopControl: Correct Fortran macros; provide Fortran wrappers LoopControl: More self-checking TestLoopControl: Correct errors in testing ghost zones LoopControl: Rename macro arguments to help avoid name clashes CarpetLib, LoopControl: Correct required/optional capabilities CarpetLib: Implement and correct head, tail, init, last in the vect class CarpetRegrid2: Correct min_fraction LoopControl: Correct Fortran OpenMP definitions LoopControl: Add debug assert statements when array padding is enabled LoopControl: Avoid compiler warnings CarpetRegrid2: Output all verbose messages with veryverbose as well CarpetRegrid2: Correct another error in handling min_fraction LoopControl: Reduce number of arguments passed to selftest routine LoopControl: Remove restrict qualifiers from shared data structures CarpetLib: Change default to interpolate_from_buffer_zones=no Carpet: Beautify screen output CarpetLib: Do not memoize OpenMP thread id LoopControl: Remove trivial vector lengths for j and k direction LoopControl: Simplify STL data type usage LoopControl: Improve OpenMP parallelisation CarpetProlongateTest: Correct default parameter values for interpolator test LoopControl: Output statistics to a file instead of stdout LoopControl: Share cache lines for SMT threads LoopControl: Correct parallelisation errors (mark variables volatile) CarpetReduce: Improve code layout Revert "CarpetLib: Change default to interpolate_from_buffer_zones=no" CarpetLib: Store level-wide set of buffer zones CarpetLib: Correct implementation of "don't interpolate from buffer zones" CarpetLib: Set interpolate_from_buffer_zones to "no" by default Carpet: New aliased function GetRegriddingEpochs CarpetIOASCII: Use CCTK_BUILTIN_UNREACHABLE CarpetIntegrateTest: Use ReflectionSymmetry for bitant mode Replace Cactus complex number type with C/C++ complex numbers CarpetProlongateTest: Increase test case tolerances for higher order prolongation CarpetIntegrateTest: Modernize test parameter file Carpet: Add CactusTimer functions to get all clock values of a timer Carpet: Output timer tree at shutdown CycleClock: Add parameter to disable registering a Cactus clock LoopControl: Output statistics into per-process files, not into a single file Carpet: Output all clocks in the timer tree Carpet: Use C++ style cast to avoid compiler warning Carpet: Correct output of load balancing statistics CarpetReduce: Don't require a valid cctkGH unless really needed CarpetReduce: New parameter min_max_time_interpolation LoopControl: Simplify #if sequence LoopControl: Improve OpenMP parallelisation of get_num_fine_threads CarpetIO*: Output complex numbers as pair of real numbers Requirements: New thorn Replace abs() by fabs() Requirements: Use vector instead of set to store ignored variables Requirements: White space cleanup Carpet: Call Requirements before, not after the respective actions Requirements: Beautify code Requirements: Remove dependency on defs.hh Requirements: Remove duplication from info messages Requirements: Add todo-note to invalidate non-written regions in partial projections Requirements: Break lines to make code more readable Requirements: Minor code re-shuffling and cleanup Carpet, Requirements: Pass timelevel_offset Requirements: Some source code cleanup Requirements: Add Frank's html generator script Requirements: Rename parameter print_changes to output_changes Requirements: Simplify logic to detect changes in gridpoint_t Requirements: Warn about Requirements.hh being publicly visible Requirements: Re-order if statement (no change in meaning) Requirements: Modify iteration arguments in Requirements.hh Carpet: Do not restrict variables marked as "don't restrict" Requirements: Remove some duplicate code Requirements: Correct handling of timelevels in BeforeRoutine and AfterRoutine Carpet: Don't call Requirements when only asking about allocated storage Requirements: Don't use identifiers starting with an underscore Requirements: Unify order of #include statements Requirements: Change location output format Requirements: Output iteration number in warnings and error messages Requirements: Change location output order; output map before timelevel Requirements: Use location_t to output warnings and errors CarpetLib: Remove unused/unfinished bboxtree class Carpet: Exit restriction early if no groups should be restricted Carpet: Small performance improvement in SyncGroupsByDir Carpet: Take tapering into account during postrestrict Requirements: Whitespace change CarpetLib: Vectors is currently required, not optional CarpetReduce: Offset reduction weights when periodic boundaries are used CarpetLib: Correct alignment mechanism when allocating memory
Frank Löffler (15): CarpetIOHDF5: cast string constant to char array to get rid of compiler warning CarpetIOHDF5: comment unused variable (commented because code using it is also commented CarpetRegrid2: Allow pseudo-2D domains CarpetRegrid2: Testsuite for trivial domains in z direction Merge branch 'master' of carpetcode.org:carpet output more verbose info (variable index and nr of timelevels make gridpoint_t a class make bool members of gridpoint_t class private, provide accessors and use them Merge branch 'master' of carpetcode.org:carpet Let set_ accessors return whether something was changed Make set_* functions be void again, add location_t struct (unused so far) use parameter to enable output if state of variable changes Requirements: pass iteration down and print in debug output; also print when something changes (readable string) swap upper/lower case for location output Requirements: fix a couple of bugs in the debug output
Ian Hinder (13): Support more than one hierarchy of timers Add a timer tree for measuring time spent in each Carpet mode Requirements: Add comments Requirements: Move clause class into separate files Requirements: Move clauses class and some utility functions to separate files Requirements: Move all_clauses class to a separate file Requirements: Move location class to a separate file Revert part of "Requirements: Beautify code" Requirements: Move gridpoint class to a separate file Requirements: Move all_state class to separate files Requirements: Move flag variables into gridpoint class Requirements: Pass all_clauses as a reference argument rather than using a global variable Requirements: Remove unneeded #includes
Peter Diener (2): Fix in order to compile with IBM compilers. Merge branch 'master' of carpetgit@carpetcode.org:carpet
Roland Haas (14): Carpet: fix mg level count typo during intialization CarpetIOASCII: do not output coordinate column labels for grid arrays in CarpetIOHDF5: output index files for sliced output if requested CarpetIOHDF5: close all HDF5 objects when output file is closed CarpetIOHDF5: fix check for missing datasets when called in FileReader mode CarpetLib: add volume averaged cc eno operator CarpetLib: support padding in non-OpenMP transport operator CarpetLib: clear boundary slice offsets in dh::regrid() CarpetProlongateTest: restrict tests to 2 processes, reduce regions, CarpetEvolutionMask: compute a mask indicating where buffers are CarpetEvolutionMask: limit buffer_mask test to one process CarpetIOHDF5: remove index files along with checkpoint files Requirements: add missing include file LoopControl: disable smt by default
-----------------------------------------------------------------------
hooks/post-receive -- Carpet — Adaptive Mesh Refinement for the Cactus Framework http://carpetcode.org/