#46: mdb defaults are ignored ------------------------+--------------------------------------------------- Reporter: eschnett | Owner: mthomas Type: defect | Status: new Priority: critical | Milestone: Component: SimFactory | Version: Keywords: | ------------------------+--------------------------------------------------- I cannot sync from my notebook to numrel02; the error message is:
$ ./simfactory/sim sync numrel02 sim: manage and submit cactus jobs
defs: /Users/eschnett/EinsteinToolkit-hg/simfactory/etc/defs.ini defs.local: /Users/eschnett/EinsteinToolkit- hg/simfactory/etc/defs.local.ini
using machines: ['numrel02']
current working directory: /Users/eschnett/EinsteinToolkit-hg
Cactus Directory: /Users/eschnett/EinsteinToolkit-hg Enabled Options: sync-parfiles: True sync-sourcetree: True
Error: machine entry redshift does not have a user defined
The mdb entry for redshift does not define the user, but I have a default setting for the user.
If I circumvent this problem by setting the user for redshift, then I receive the next error:
Error: machine redshift is missing a required key: rsynccmd
This key has a default value in mdb-syntax.ini, but is apparently also not set.