#685: Cleanup in script CreateConfigurationBindings.pl --------------------------+------------------------------------------------- Reporter: eschnett | Owner: Type: enhancement | Status: review_ok Priority: minor | Milestone: Component: Cactus | Version: Resolution: | Keywords: --------------------------+------------------------------------------------- Changes (by bmundim):
* status: review => review_ok
Comment:
This patch clean-up CreateConfigurationBindings.pl in several different ways: rename scalar variables to improve readability, get rid of temporary variable, apply proper variable scoping, reorder script execution. I looked carefully into this patch and have only two minor comments (that can be addressed after applying this patch):
1) In the original file there was not prepending of #include as it shows now on line 104 of the patched file:
# Prepend #include $inc =~ s/^(.*)/#include $1/gm; $incs .= $inc;
Was this intentional?
2) Fix typo on line 110: # These string --> # These strings
Other than that the patch looks good and improves readability of the script. Please apply!