#461: Filter rules error when using rsync 2.6.9 -------------------------+-------------------------------------------------- Reporter: hinder | Owner: eschnett Type: defect | Status: new Priority: blocker | Milestone: Component: SimFactory | Version: Resolution: | Keywords: -------------------------+--------------------------------------------------
Comment (by eschnett):
I prefer MDB entries that are as small as possible. Things that can be done automatically should be done automatically. Only things that are impossible to detect at run time should be in the MDB.
I assume that rsync returns an error code. It should be easy to construct a command such as
rsync-with-permissions || rsync-without-permissions
which would do the "right thing" automatically.
Or maybe even
rsync-with-permissions || rsync-without-permissions || { ssh mkdir && { rsync-with-permissions || rsync-without-permissions } }