#213: "cleanup" is implemented twice -------------------------+-------------------------------------------------- Reporter: eschnett | Owner: mthomas Type: defect | Status: closed Priority: minor | Milestone: Component: SimFactory | Version: Resolution: wontfix | Keywords: -------------------------+-------------------------------------------------- Changes (by mthomas):
* status: new => closed * resolution: => wontfix
Comment:
these are different enough in functionality. I'm not going to change this. CleanupRestarts operates in a non-interactive mode, getting a list of all simulations, and all restarts from each simulation, and attempts to clean each of these up. command_cleanup allows the specification of certain simulations, with certain restarts. The duplicate code is only about two lines.