#311: TimerReport: Allow user to disable scheduled function timer table --------------------------+------------------------------------------------- Reporter: hinder | Owner: Type: enhancement | Status: review Priority: minor | Milestone: Component: Cactus | Version: Resolution: | Keywords: TimerReport --------------------------+-------------------------------------------------
Comment (by eschnett):
I usually set the option
TimerReport::out_filename = "TimerReport"
to redirect this output into files. This has the added advantage that it provides timing information for all processes, which can be very useful -– timing information from a single process only is misleading and should probably be disabled by default.
To avoid confusion, all parameters that influence the schedule timers should have similar names. Your new parameter is called output_schedule_timers. Do you want to rename out_filename as well, so that it has "schedule" in its name?
Another way would be to handle screen output and file output for schedule timers via separate parameters. The new boolean decides on screen output, and the file name decides only on file output; an empty file name disables file output instead of enabling screen output.