#1535: Outflow: add option for computing the flow of unbounded matter ------------------------------------+--------------------------------------- Reporter: dradice@… | Owner: Type: enhancement | Status: reopened Priority: minor | Milestone: Component: EinsteinToolkit thorn | Version: development version Resolution: | Keywords: ------------------------------------+--------------------------------------- Changes (by rhaas):
* status: review => reopened
Comment:
The patch is mostly fine. However it removes the magic value "-1" from the threshold parameter description without removing the magic value handling code (look for "is set to -1, ignoring."). I am in principle fine removing the magic value, however in case someone actually used this, it would be better to keep the magic value in param.ccl but 1. document in param.ccl that this only works with w_lorentz 2. moves the code that skips int the threshold_on_w_lorentz branch is the if statement or if we are sure that u_t > -1 for all "valid" points anyway we can also just re-add the magic value to param.ccl.