#1316: Piraha's smart_ptr should be in namespace ----------------------+----------------------------------------------------- Reporter: eschnett | Owner: Type: defect | Status: new Priority: major | Milestone: ET_2013_05 Component: Cactus | Version: Keywords: | ----------------------+----------------------------------------------------- Piraha defines a helper class smart_ptr (and smart_ptr_guts). These should be located in a namespace.
Probably all of Piraha should be in the namespace cctk. As is, any user who tried to use Piraha in a thorn would be out of luck, since the name "piraha" is now globally already taken.
#1316: Piraha's smart_ptr should be in namespace -----------------------+---------------------------------------------------- Reporter: eschnett | Owner: Type: defect | Status: closed Priority: major | Milestone: ET_2013_05 Component: Cactus | Version: Resolution: fixed | Keywords: -----------------------+---------------------------------------------------- Changes (by eschnett):
* status: new => closed * resolution: => fixed
Comment:
In addition to these type names there was also a global variable "ptrs".
I changed Piraha's namespace from "piraha" to "cctki_piraha", as per Cactus naming conventions.
I moved smart_ptr into this namespace as well.
trac@lists.einsteintoolkit.org