#1316: Piraha's smart_ptr should be in namespace -----------------------+---------------------------------------------------- Reporter: eschnett | Owner: Type: defect | Status: closed Priority: major | Milestone: ET_2013_05 Component: Cactus | Version: Resolution: fixed | Keywords: -----------------------+---------------------------------------------------- Changes (by eschnett):
* status: new => closed * resolution: => fixed
Comment:
In addition to these type names there was also a global variable "ptrs".
I changed Piraha's namespace from "piraha" to "cctki_piraha", as per Cactus naming conventions.
I moved smart_ptr into this namespace as well.