#1243: Allow pseudo-2D domains in CarpetRegrid2 --------------------+------------------------------------------------------- Reporter: knarf | Owner: knarf Type: defect | Status: new Priority: major | Milestone: ET_2013_05 Component: Other | Version: development version Keywords: | --------------------+------------------------------------------------------- Currently CarpetRegrid2 contains two asserts that fail for domains that are effectively 2D (but defines as 3D arrays, e.g. (nx,ny,1). The attached patch makes sure these domains don't trigger the assert by checking for ilower==iupper. I also attached a parfile intended as testsuite for this case.
#1243: Allow pseudo-2D domains in CarpetRegrid2 ---------------------+------------------------------------------------------ Reporter: knarf | Owner: knarf Type: defect | Status: review Priority: major | Milestone: ET_2013_05 Component: Other | Version: development version Resolution: | Keywords: ---------------------+------------------------------------------------------ Changes (by knarf):
* status: new => review
#1243: Allow pseudo-2D domains in CarpetRegrid2 ---------------------+------------------------------------------------------ Reporter: knarf | Owner: knarf Type: defect | Status: reviewed_ok Priority: major | Milestone: ET_2013_05 Component: Other | Version: development version Resolution: | Keywords: ---------------------+------------------------------------------------------ Changes (by eschnett):
* status: review => reviewed_ok
Comment:
Can you rename boundary_is_trivial to domain_is_trivial?
Okay to apply.
#1243: Allow pseudo-2D domains in CarpetRegrid2 ---------------------+------------------------------------------------------ Reporter: knarf | Owner: knarf Type: defect | Status: closed Priority: major | Milestone: ET_2013_05 Component: Other | Version: development version Resolution: fixed | Keywords: ---------------------+------------------------------------------------------ Changes (by knarf):
* status: reviewed_ok => closed * resolution: => fixed
Comment:
Renamed and pushed as of 0d0fb2b..55f4ce8
trac@lists.einsteintoolkit.org