#2483: Simfactory job parameters are not consistent
Reporter: Steven R. Brandt
Status: new
Milestone:
Version:
Type: bug
Priority: major
Component: SimFactory
Comment (by Steven R. Brandt):
“--total-threads” is just a new name for the number of parallel thingies, which aren’t really “cores” and aren’t really “procs.”
As for “--nodes” and “--node-procs” it offers a way to directly specify how you want mpi to do, rather than doing a calucation based on cores/procs/total-threads. I suspect I’m not the only one who would find that more convenient.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2483/simfactory-job-pa…
#2483: Simfactory job parameters are not consistent
Reporter: Steven R. Brandt
Status: new
Milestone:
Version:
Type: bug
Priority: major
Component: SimFactory
Comment (by Roland Haas):
I suspect that `--total-threads` will still require smt information since `--total-threads = --procs * --num-threads` so there is no extra information available. The smt stuff is really used for the queuing system since those sometimes need to know whether the code uses smt or not \(since they want a ppn like value and that differs between smt and non-smt\).
I am not trying to suggest nodes and nodes procs, no. I am suggesting to use the names items used by `mpirun` which is “number of MPI ranks” and OS threads \(`OMP_NUM_THREADS`\). smt will still be required \(same reason as for `--total-threads`\). Ie re-use names and nomenclature that people who are using a cluster are already familiar with.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2483/simfactory-job-pa…
#2483: Simfactory job parameters are not consistent
Reporter: Steven R. Brandt
Status: new
Milestone:
Version:
Type: bug
Priority: major
Component: SimFactory
Comment (by Steven R. Brandt):
I chose the term “total threads” because that’s what all of the documentation uses. You have stated previously that you think you don’t want to support the terminology in the documentation. There is a PR \(the \`fixsub\` branch of simfactory\) which implements `--total-threads`. It also introduces `--nodes` and `--node-procs` which \(I think\) is the functionality you are suggesting with `--ranks` or `--mpi-ranks`. It also introduces `--test` to see whether the simfactory options you provide do what you think they do.
I would be perfectly happy to name all these options something different, but I would like to see this PR accepted in some form, as both `--procs` and `--cores` are not the things that they are named after. I have frequently been confused by the behavior of these parameters.
An alternative to the `--total-threads` would be to simply get rid of the smt stuff, which was the source of much confusion for me.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2483/simfactory-job-pa…
#2586: new cGH field cctk_patch
Reporter: Roland Haas
Status: open
Milestone:
Version: development version
Type: enhancement
Priority: minor
Component: Cactus
Comment (by Roland Haas):
Note that to find out the total number of patches \(maps\) one still has to call the aliased functon `GetMaps`. Not sure if there is a legit use for that information though \(there is also not official way to find out the total number of components \[not MPI ranks\]\). Also note that the assumption `cctk_patch == 0` → Cartesian patch is most likely not true for eg the 6 patch cubed sphere system \(which has no Cartesian block in the center\). The function to query this would be `MultiPatch_MapIsCartesian` in the `Coordinates` thorn \(which only requires knowledge of `cctk_patch` and of course calls it `map`\).
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2586/new-cgh-field-cct…
#2586: new cGH field cctk_patch
Reporter: Roland Haas
Status: open
Milestone:
Version: development version
Type: enhancement
Priority: minor
Component: Cactus
Comment (by Roland Haas):
Please apply.
Requests:
* document `cctk_patch` in the UsersGuide
* in the UsersGuide replace all use of “patch” meaning “disjoint grid patch” by “component” to avoid using “patch” for 2 different things \(at least in the docs. Carpet still uses “patch” for “component” eg in CarpetIOHDF5’s checkpoint file handling code\).
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2586/new-cgh-field-cct…