#2563: remove use of finite() function call superceded by isfinite in C99
Reporter: Roland Haas
Status: new
Milestone:
Version: development version
Type: bug
Priority: major
Component:
Comment (by Roland Haas):
Unless objected I will apply these after 2021-09-30.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2563/remove-use-of-fin…
#2551: include RePriMand in the ET
Reporter: Roland Haas
Status: new
Milestone: ET_2021_11
Version: development version
Type: enhancement
Priority: major
Component:
Changes (by Roland Haas):
milestone: ET_2021_11 (was )
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2551/include-reprimand…
#2549: inlcude FLRWSolver in ET
Reporter: Roland Haas
Status: new
Milestone: ET_2021_11
Version: development version
Type: enhancement
Priority: major
Component:
Changes (by Roland Haas):
milestone: ET_2021_11 (was )
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2549/inlcude-flrwsolve…
#2549: inlcude FLRWSolver in ET
Reporter: Roland Haas
Status: new
Milestone:
Version: development version
Type: enhancement
Priority: major
Component:
Comment (by Roland Haas):
Trying to run \`builder.py\` I find that it requires the cffi package which should be mentioned \(as well as any other dependencies not in the base Python set of packages\).
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2549/inlcude-flrwsolve…
#2549: inlcude FLRWSolver in ET
Reporter: Roland Haas
Status: new
Milestone:
Version: development version
Type: enhancement
Priority: major
Component:
Comment (by Roland Haas):
A thornlist stanza to check out FLRWSolver can look like this:
```
# FLRWSolver
# strange path is due to repo name
!TARGET = $ARR
!TYPE = git
!URL = https://github.com/hayleyjm/FLRWSolver_public.git
!NAME = FLRWSolver
!REPO_PATH= ../$2
!CHECKOUT =
EinsteinInitialData/FLRWSolver
```
where I mimic the naming convention \(up to capitialization\) suggested in README.Compilation to name the checkout FLRWSolver rather than FLRWSolver\_public \(this also makes the stanza using a bit less strange REPO\_PATH\).
Currently \(without running bulder.py\) fails to compile so is not “harmless” to include in master \(since it prevents the thornlist from compiling\).
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2549/inlcude-flrwsolve…
#2487: *_evolution_method = "LeanBSSNMoL" in Lean does nothing
Reporter: Gabriele Bozzola
Status: open
Milestone:
Version: development version
Type: bug
Priority: major
Component: EinsteinToolkit thorn
Comment (by Roland Haas):
You will have to consider what will happen to existing parfiles that may not have set the admbase parameters. These would fail \(or at least behave differently\) and ideally we want to reduce the cases where the same parfile produces different physics when run with different ET versions. Not checking the gauge evoluion method was a bug so in principle all “correct” parfiles that did set the gauge parameter to “lean” should continue to work fine. You may want to check what eg your example parfile did do.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2487/_evolution_method…
#2487: *_evolution_method = "LeanBSSNMoL" in Lean does nothing
Reporter: Gabriele Bozzola
Status: open
Milestone:
Version: development version
Type: bug
Priority: major
Component: EinsteinToolkit thorn
Comment (by Miguel Zilhão):
Unless anyone objects, I’d be happy to merge this with `master`.
--
Ticket URL: https://bitbucket.org/einsteintoolkit/tickets/issues/2487/_evolution_method…