#1859: use OPENSSL_DIR variable instead of SSL_DR ------------------------+--------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: new Priority: minor | Milestone: Component: SimFactory | Version: development version Keywords: | ------------------------+--------------------------------------------------- This is pull request
https://bitbucket.org/simfactory/simfactory2/pull-requests/2/use- openssl_dir-rather-than-ssl_dir/diff
for simfactory. The ExternalLibrary only looks at OPENSSL_DIR and not SSL_DIR. Currently the simfactory files only contain comments commenting on the fact that SSL_DIR will likely be ignored. Since we know it will be ignored it seems better to use the correct OPENSSL_DIR variable.
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: new Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: | Keywords: -------------------------+--------------------------------------------------
Comment (by knarf):
I'd rather see SSL_DIR used instead. SSL is what is provided, and OpenSSL only one possible implementation. We should have OPENSSL_DIR also recognized probably, with lower priority than SSL_DIR.
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: new Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: | Keywords: -------------------------+--------------------------------------------------
Comment (by eschnett):
The library is called "OpenSSL". There is no generic "SSL" library, comparable e.g. to a "LAPACK". Alternative libraries have different names, e.g. "mbedTLS", with different APIs.
We also always use configuration variable names that have the thorn name as prefix.
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: new Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: | Keywords: -------------------------+--------------------------------------------------
Comment (by knarf):
Ok.
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: review Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: | Keywords: -------------------------+-------------------------------------------------- Changes (by anonymous):
* status: new => review
Comment:
Well does this mean "please apply"? In that case would someone (other than me) please set the state to "reviewed"?
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: reviewed_ok Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: | Keywords: -------------------------+-------------------------------------------------- Changes (by knarf):
* status: review => reviewed_ok
Comment:
At that moment it didn't mean 'approved', since that was only about the variable name. Now it is. :)
#1859: use OPENSSL_DIR variable instead of SSL_DR -------------------------+-------------------------------------------------- Reporter: rhaas | Owner: Type: defect | Status: closed Priority: minor | Milestone: Component: SimFactory | Version: development version Resolution: fixed | Keywords: -------------------------+-------------------------------------------------- Changes (by rhaas):
* status: reviewed_ok => closed * resolution: => fixed
Comment:
Applied in git hash 1e88f53 of OpenSSL
trac@lists.einsteintoolkit.org