#389: show-output does not expand @SIMULATION_NAME@
------------------------+---------------------------------------------------
Reporter: eschnett | Owner: mthomas
Type: defect | Status: new
Priority: major | Milestone:
Component: SimFactory | Version:
Keywords: |
------------------------+---------------------------------------------------
show-output does not expand @SIMULATION_NAME@ in the mdb entries it uses.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/389>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#384: Failing test cases are marked in grey, not in red
-------------------------------------+--------------------------------------
Reporter: eschnett | Owner:
Type: defect | Status: new
Priority: minor | Milestone:
Component: EinsteinToolkit website | Version:
Keywords: |
-------------------------------------+--------------------------------------
On page <http://einsteintoolkit.org/release-
info/parse_testsuite_results.php>, the failing test cases in the second
line are marked in grey, not in red.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/384>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#378: Perl simfactory has redundant ini files
--------------------+-------------------------------------------------------
Reporter: hinder | Owner:
Type: defect | Status: new
Priority: major | Milestone: ET_2011_05
Component: Other | Version:
Keywords: |
--------------------+-------------------------------------------------------
As far as I know, the Perl version of SimFactory does not use the .ini
file format. However, there are several files around in the repository
which make it look like it does:
MacBook:simfactory ian$ find . -name "*.ini"
./cdb.ini
./mdb/abe.ini
./mdb/ac.ini
./mdb/bp.ini
./udb.example.ini
as well as an "inifiles" directory. This is confusing as when you first
check it out, you don't know which files to customise.
I propose that these files be removed.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/378>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#377: re-gerenate Kranc based thorns for release
-----------------------------------+----------------------------------------
Reporter: rhaas | Owner: rhaas
Type: enhancement | Status: new
Priority: minor | Milestone: ET_2011_05
Component: EinsteinToolkit thorn | Version:
Keywords: |
-----------------------------------+----------------------------------------
Kranc has changed since the last release. updating WeylScal4 and McLachlan
for the next release would make sense.
As a side affect this would fix testsuite
ML_BSSN_Test/gw3d_McLaclan_ord4_15 which uses thorn Periodic but does not
currently select boundary conditions for McMlachlan's variables. IE. the
following block is missing:
ML_BSSN::ML_curv_bound = "none"
ML_BSSN::ML_dtlapse_bound = "none"
ML_BSSN::ML_dtshift_bound = "none"
ML_BSSN::ML_Gamma_bound = "none"
ML_BSSN::ML_lapse_bound = "none"
ML_BSSN::ML_log_confac_bound = "none"
ML_BSSN::ML_metric_bound = "none"
ML_BSSN::ML_shift_bound = "none"
ML_BSSN::ML_trace_curv_bound = "none"
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/377>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#376: Rename "holdingpattern" to "heldpattern"
------------------------+---------------------------------------------------
Reporter: eschnett | Owner: mthomas
Type: defect | Status: new
Priority: minor | Milestone:
Component: SimFactory | Version:
Keywords: |
------------------------+---------------------------------------------------
The correct expression is "a job is held", hence the corresponding MDB key
should be "heldpattern".
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/376>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#373: test/qlm-bl.par in QuasiLocalMeasures
-----------------------------------+----------------------------------------
Reporter: rhaas | Owner:
Type: defect | Status: new
Priority: minor | Milestone: ET_2011_05
Component: EinsteinToolkit thorn | Version:
Keywords: QuasiLocalMeasures |
-----------------------------------+----------------------------------------
QuasiLocalMeasures: in test/qlm-bl.par schedule AHFinderDirect in ANALYSIS
instead of POSTSTEP so that Carpet::init_3levels works. Otherwise
AHFinderDirect runs on negative time levels and the interpolator fails due
to
lack of timelevels in AHmask. Reducing prolongation_order_time does not
help
since init3_levels needs prolongation_order_time==2 apparently.
I cannot apply this patch since QLM is in LSUThorns. Would someone at LSU
look at it and apply it, please? With it the test runs and mostly passes.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/373>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#216: Thorns in ExternalLibraries should abort if the old "extras" mechanism has
been selected
-------------------------------+--------------------------------------------
Reporter: hinder | Owner:
Type: enhancement | Status: new
Priority: minor | Milestone:
Component: Cactus | Version:
Keywords: ExternalLibraries |
-------------------------------+--------------------------------------------
The old way of specifying the location of external libraries, from
Cactus/lib/make/extras, for example setting HDF5 = yes, is not compatible
with the new mechanism where you must simply include the appropriate thorn
from ExternalThorns. Using both can be confusing.
I propose modifying the thorns in ExternalLibraries to check if the old
mechanism has been selected, and to abort with an explanatory error
message telling the user not to set, e.g. HDF5 = yes, if they are using
ExternalLibraries/HDF5.
I am attaching a completely untested patch for the HDF5 thorn which
implements something like this. The code to determine if the user
selected HDF5 = yes was taken from the extras directory.
Comments? If this is appropriate, it can be adapted to all the thorns in
ExternalLibraries.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/216>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#318: add "Report bug" link to Einstein Toolkit sidebar item
-------------------------------------+--------------------------------------
Reporter: rhaas | Owner: rhaas
Type: enhancement | Status: new
Priority: optional | Milestone:
Component: EinsteinToolkit website | Version:
Keywords: |
-------------------------------------+--------------------------------------
Is there a link somehwere on the ET website to link to the Issue tracker?
If not I'd like to add it undernead the Contribute link, ie:
{{{
Index: global/navigation.php
===================================================================
--- global/navigation.php (revision 463)
+++ global/navigation.php (working copy)
@@ -16,6 +16,7 @@
<li><a href="/toolkit/capabilities/">Capabilities</a></li>
<li><a href="/toolkit/community/">Mail Lists</a></li>
<li><a href="/info/contribute/">Contribute</a></li>
+ <li><a href="https://trac.einsteintoolkit.org">Report
issues</a></li>
<li><a href="/info/citing/">Cite</a></li>
</ul></li>
}}}
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/318>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit
#302: Multipole HDF5 file truncation with multiple variables
-----------------------+----------------------------------------------------
Reporter: hinder | Owner:
Type: defect | Status: new
Priority: minor | Milestone:
Component: Other | Version:
Keywords: Multipole |
-----------------------+----------------------------------------------------
Previously a "first_time" variable was used to determine if truncation
should happen. When decomposing multiple variables, this logic is
incorrect. We now store the first_time information per output file.
I have tested the patch.
--
Ticket URL: <https://trac.einsteintoolkit.org/ticket/302>
Einstein Toolkit <http://einsteintoolkit.org>
The Einstein Toolkit