On 30 Nov 2010, at 21:21, Erik Schnetter wrote:
On Tue, Nov 30, 2010 at 3:19 PM, Ian Hinder ian.hinder@aei.mpg.de wrote:
[schnipp]
Of course! I was confused about this, but you're right, it should work OK that way. Given that it is safe for all thorns to include cctk_Capabilities.h, should we just include it in cctk.h for all thorns?
Yes, I think this would be good. I don't see any real advantage in introducing another user-level include file (but this is a question of taste).
The attached patch implements the things we have discussed. An appropriate commit message would be:
Improve optional capability requirement
* Introduce makefile and preprocessor variables HAVE_CAPABILITY_<cap> for each provided capability
* Remove incorrect definition line
* Rename cctki_Capabilities.h to cctk_Capabilities.h and exclude it from dependency checking (dependencies of the files included from this one will be sufficient) <<<