Hello Giuseppe,
HDF5_LIBS = /lrz/sys/io_tools/hdf5/1.8.15/serial_icc17/lib HDF5_INC = /lrz/sys/io_tools/hdf5/1.8.15/serial_icc17/include
these variables should be called HDF5_LIB_DIRS and HDF5_INC_DIRS (see eg https://bitbucket.org/simfactory/simfactory2/src/463a900955cd0a62ac4af064b20...) though I think it will also work if you remove those two (but keep HDF5_DIR).
Yours, Roland