Hello,
I am trying to run the static_tov simulation on my university's cluster (CRC Notre Dame https://docs.crc.nd.edu/new_user/quick_start.html). However, I got this error when acquiring 48 cores:
Error: Too many nodes specified: nodes=2 (maxnodes is 1)
I am assuming this is due to the *#Source tree management* module in the Cactus/simfactory/mdb/machines/<host>.ini file. In my case, the automatic *.ini file I got has these configuration:
ppn = 24
max-num-threads = 24
num-threads = 12
nodes = 1
However, the machine I use has 24 cores for each node, and the number of threads for each core is 1. That means if I run the simulation using 48 cores, I need 2 nodes.
Although I didn't get 2 hosts successfully(I got only 1), I am wondering if I have to edit the <host>.ini file after the command ./simfactory/bin/sim setup-silent by hand, for example: num-threads=1, nodes=2? Or is there any other correct way for getting more than 1 node?
I would be appreciate it if you could give me some ideas on this problem.
Best regards, Wei